Using WHM Migrate Plugin for Migrating Accounts


NOTE: THIS GUIDE IS DEPRECATED.

Auto Detection: Supported systems

JetMigrate will automatically recognize known systems such as WordPress, Joomla, Drupal, etc. and will modify the data structure accordingly based on the known system to assure it works properly in its new account environment.

Here is a list of the supported systems –

  • Joomla (All Versions since 1.5)
  • WordPress
  • SMF
  • PrestaShop
  • PHP-Fusion
  • PHPBB
  • Oxwall
  • OpenCart
  • MyBB
  • Drupal 8
  • Dolphin
  • CubeCart
  • ClipBucket
  • AbanteCart

Troubleshooting the Migration Process

Below are listed common errors and steps to resolve.

Migration : Minimum Reseller Privileges Needed

When trying into migrate into a reseller account with insufficient privileges, you will receive the following error from JetMigate:

Connection established using the provided credentials. However, the provided reseller account does not hold sufficient privileges in order to continue. The needed privileges are:
X Account Management :: Create
X Account Management :: Edit MX Entries
X Packages :: Add/Remove
X Dns :: Edit

To grant the needed privileges to the reseller, please navigate to WHM -> Edit Reseller Nameservers and Privileges -> Choose Reseller. Check each feature to ensure the correct privileges are assigned.

Jetmigrate

This Migration Process is Locked

You can encounter a “Migration is locked” message if someone else already started a migration process for that particular cPanel account. If you will still try to migrate the account, there will be an error message:

Something went wrong. Current account is locked.

The lock was created in order to prevent two persons to work on the same migration, and accidentally overwrite each other’s settings.

All locks are defaulted to 5 minutes, if there is no “heartbeat” from the original opening person, the migration lock will be automatically terminated and the account will be available of migration by anyone.

Selection_159

Selection_160

You are not Allowed to Use this Program

In some scenarios, You might receive an error while migrating an account –

You are not allowed to use this program (crontab)

This error can occur mainly because of two reasons –

1. The “Cron Tab” feature is disabled in the package feature list (under WHM)
2. Not enough permissions for the crontab binary –

stat -c '%n %a' /usr/bin/crontab
/usr/bin/crontab 755

The permissions should be 4755. To fix, login as root user and run the following commands from the terminal.

chmod 4755 /usr/bin/crontab
stat -c '%n %a' /usr/bin/crontab
/usr/bin/crontab 4755
  • jetmigrate, migrate plugin, migrating to rad web hosting, server migration
  • 2 Kunder som kunne bruge dette svar
Hjalp dette svar dig?

Related Articles

Install WHMCS Module for Hosting Resellers

NOTE: THIS GUIDE IS DEPRECATED. This is a guide to Install the WHMCS Reseller Module that is...

Install WHMCS Module for Reselling Dedicated Servers

NOTE: THIS GUIDE IS DEPRECATED. This article provides a guide for installing the Dedicated...